Topics

FYI: Rails upgrade for BadgeApp

David A. Wheeler
 

FYI: In our effort to keep the Best Practices Badge website running smoothly, we just upgraded from the Rails 5.1 to Rails 5.2 (specifically version 5.2.2).

 

If you notice a problem, please let us know!!

 

Rail 6 will come out April 30 of 2019; at that time, Rails 5.1 will stop receiving guaranteed security updates.  So we really needed to upgrade at some point, and it’d be safer to do that now.  This required a few subtle changes, which were resolved.

 

Everything seems to be fine (so far) on the upgraded system.  We have a decent automated test suite; the test suite did detect some problems with a “naïve” upgrade, but we corrected those problems before we even merged it into our initial-test tier (“master”).  If desperate we can revert the running version & switch to a backup database, but hopefully it will never come to THAT J.

 

--- David A. Wheeler